package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[3-5\x{0663}-\x{0665}]`)
var str = `0123456789
٠١٢٣٤٥٦٧٨٩`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}