$re = '/^[a-zA-Z0-9_-]+(?: [a-zA-Z0-9_-]+)*$/';
$str = 'Test regex -121-test valid future_4 %$^&.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);