package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*\b(1)\b.*`)
var str = `1,3`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}