package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:https?:\/\/)?(?:www\.)?(?:drive\.google\.com\/drive\/folders\/)(.+)[\?\$]`)
var str = `https://drive.google.com/drive/folders/1q5nL2z8yKS-0qvmlt9Jtq8u3iFgsu-ea
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}