$re = '/^(?=.{0,20}$)([a-zA-Z ]+)$/m';
$str = '01234567890123456789Basil';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);