import re
regex = re.compile(r"(?m)^:\S+:", flags=re.MULTILINE)
test_str = (":name-of-an-attribute:\n"
":name-of-an-attribute: value of the attribute\n"
":url-org: https://example.org/projects\n"
":url-project: {url-org}/project-name\n\n"
"https://docs.asciidoctor.org/asciidoc/latest/attributes/attribute-entries/\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")