using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!\d+$)(?:[a-zA-Z0-9][a-zA-Z0-9 @&$]*)?$";
string input = @"Sharpeye500@
Sharpe.Eye500";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}