$re = '/[^0\n\r].*/m';
$str = 'ABC0123
0ABC0123
000ABC0123
01000
test';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);