$re = '~(?:(?![#/])[[:punct:][:space:]])+~m';
$str = '#a-v^y&i***o/9\\0';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;