const regex = /[^\p{L}\p{N}]+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^\\p{L}\\p{N}]+', 'gm')
const str = `Я – робот123!N`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);