import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d+$";
final String string = "сгущенка\n"
+ "привет сгущенка как тдеда\n"
+ " 92 наоборот\n"
+ "92 наобот\n"
+ "skalik92 хай!\n"
+ "(?<!skalik)92\n"
+ "92\n"
+ "14\n"
+ "96\n"
+ "95 asfasdf\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}