package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\((\w+):\d+\)`)
var str = `(int:5)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}