re = /[a-zA-Z0-9.!#$%&’*+\/=?^_`{|}~-]+@[a-zA-Z0-9-]+(?:\.[a-zA-Z0-9-]+)*$/m
str = '.@mail.ru
.....@mail.ru
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end