$re = '/^(?!.* {2})(?=\S)(?=.*\S$)[a-zA-Z0-9- &]{2,100}$/';
$str = 'No trailing spaces or extra spaces max char 200 min 2 and hyphen and & only allowed';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);