$re = '/(?<=:).+/';
$str = 'TEST:123 BOOK:ISBN2143123 Author:Joe Doe';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);