import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<= Name:)[\\s]+[\\d\\w]+";
final String string = "\" Primary Location: MO0134 Name: 8930 WARD PKY FEDERAL BG Ownership: Federal Status: Active Address: 8930 WARD PKWY, KANSAS CITY, MO 64114 Facility Code: (None) Facility Name: (None) File Name: STRUCT-17110-GSA_WARDPKWY - R18.RVT File Title: Struct-17110-GSA-WardPkwy-R18.rvt Timeframe: Future Conditions Primary Context: PROJ 1234567 Title: (None) Year: (None) Sub-Context: (None) Title: (None) Lifecycle Stage: Site Acquisition Document Type: BIM Sheet Type: (None) Plan Type: (None) Disciplines Process Equipment Resource Building Levels: (None) Program Association: (None) Description: Struct-17110-GSA-WardPkwy-R18.rvt Mimetype: application/x-tika-msoffice Author: (None) Size: 26808320 Creator: admin Created Date: Mon 24 Jan 2022 00:19:41 UTC Modifier: jason.zhang@gsa.gov Modified Date: Thu 07 Jul 2022 04:05:50 UTC \"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}