import Foundation
let pattern = #"^(?:(?!\bbag\b).)*\bred\b.+?\bbag\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
choose balls if they are in red bag, or they are in green bag
choose balls if they are in green bag, or they are in red bag
choose balls if they are in red bag
choose balls if they are in green bag
bag red bag
red bag red
green bag red bag
red bags
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)