package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[^*]*\*){2}[^*]*\d{3}$`)
var str = `Matching:
abc*asd*123
**123
Non-matching
abcasd*123
a*b*12`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}