re = /(?m)\[\.underline\]((#(?!#)(.*?)#(?!#))|(##(?!#)(.*?)##))/m
str = 'The text [.underline]#underline me# is underlined. +
The text [.line-through]#aaa# ist durchgestrichen.
text #just highlight#, normal text
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end