import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(?P<Date>(?:Mon|Tue|Wed|Thu|Fri|Sat|Sun), (?:Jan|Feb|Mar|Apr|May|Jun|Jul|Aug|Sep|Oct|Nov|Dec) \\d{1,2}, \\d+ \\d{1,2}:\\d{1,2} AM|PM) (?P<WarnID>(?:[0-9a-f]|-)*) (?P<User>[a-zA-Z]+#[0-9]{4}) (?:\\((?P<UserID>[0-9]+)\\)) (?P<Moderator>[a-zA-Z]+#[0-9]{4}) (?P<WarnReason>(?:\\s|\\S)+))";
final String string = "Fri, Apr 21, 2023 7:49 AM 6ab4e8de-262b-4926-a12e-646863749f35 Fir#7634 (750565290009559112) HitByaThunder#1925 continuing to make giveaways after being told to stop. fir, stop if you're asked to Stop";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}