$re = '/\(([^()]*)\)(?=(?:[^()]*\)){1})/m';
$str = '(aaa) (ee (ff (gg))) (bbb (ccc)) ddd';
$subst = "{$1}";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;