#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)(?<=<array>)(?:(?:(?!<\/?array>)[^*])*[*]){2}.*?(?=</array>)"
Local $sString = "<array>blah blah * blah blah * blah blah</array>" & @CRLF & _
"<array>blah blah blah **blah blah blah</array>" & @CRLF & _
"<array>blah blah blah blah blah blah</array>" & @CRLF & _
"<array>blah blah blah *blah blah blah</array>" & @CRLF & _
"<array>blah blah * blah blah blah blah</array>" & @CRLF & _
"<array>blah blah blah blah blah blah</array>" & @CRLF & _
"<array>blah blah blah **blah blah blah</array>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")