import re
regex = re.compile(r"\b(??px)(?<!(?<!\S)\.)(\d*)(\d)(?:\.(\d+))?px\b", flags=re.MULTILINE)
test_str = ("font-size: 10px;\n"
"border: 0px;\n"
"margin-top: 4px; // dont touch\n"
"margin-bottom: 12px;\n"
"margin-right: 50%;\n"
"margin-left: -12px;\n"
"padding-left: 120px;\n"
"padding-right: 8px;\n"
"border-radius: calc(50% - 1px); // dont touch\n"
"grid-template-columns: 1fr 44px 1fr;\n"
"margin-top: 36.4px;\n"
"border-width: 10.5px;\n"
"border-width: .3px; // dont touch\n"
"border-width: .6px; // dont touch\n"
"border-width: 3.3px; // dont touch\n"
"border-width: 6.6px 4px 8000px .34px;\n"
"margin-left: -1px; // dont touch")
subst = "$1.$2$3rem"
result = regex.sub(subst, test_str)
if result:
print(result)