package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([a-zA-Z]+[’',.\-]?[a-zA-Z ]*)+[ ]([a-zA-Z]+[’',.\-]?[a-zA-Z ]+)+$`)
var str = `hau hasdadasd`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}