use strict;
my $str = 'The.100.S07.1080p.BluRay.x264-BORDURE
The.100.S07.720p.BluRay.x264-BORDURE
The 100 - S05 - The Complete 5th Season [ 3 BD50 ] 2018 Blu-ray AVC DTS-HD MA5.1 - d69a74
The 100 - S04 - The Complete 4th Season [ 3 BD ] 2017 Blu-ray AVC DTS-HD MA5.1 - d69a74
The 100 - S03 - The Complete 3rd Season [ 4 BD ] 2016 Blu-ray AVC DTS-HD MA5.1 - d69a74
The 100 - S02 - The Complete 2nd Season [ 4 BD ] 2014-2015 Blu-ray AVC DTS-HD MA5.1 - d69a74
The 100 - S01 -The Complete 1st Season [ 3 BD ] 2014 Blu-ray AVC DTS-HD MA5.1 - d69a74
The.100.S06.1080p.BluRay.x264-TURMOiL
The.100.S06.720p.BluRay.x264-MAYHEM
A visszatérők S05 1080p
The.100.S05.COMPLETE.720p.BluRay.HUN.ENG.x264-SLN
A visszatérők S04 1080p
The.100.S04.COMPLETE.720p.BluRay.HUN.ENG.DD5.1.x264-SLN
A visszatérők S03 1080p
The.100.S03.COMPLETE.720p.BluRay.x264.HUN.ENG-SLN
The.100.S04.1080p.BluRay.x264-SHORTBREHD
A visszatérők S02 1080p
The.100.S02.COMPLETE.720p.BluRay.x264.HUN.ENG-SLN
The.100.S02.720p.HDTV.x264-MiXGROUP
The.100.S04.720p.HDTV.x264-MiXGROUP
The.100.S03.1080p.HDTV.x264-DIMENSION
The.100.S01.1080p.BluRay.DTS.x264.Hun-HOONIGAN
The.100.S01.COMPLETE.720p.BluRay.x264.HUN-ENG-SLN
The 100 S01 1080p
The.100.S02.1080p.BluRay.x264-SHORTBREHD
The.100.S02.720p.BluRay.X264-REWARD
Family.Guy.S19E04.HULU.WEB-DL.DDP5.1.H264.Eng.Hun-BNR.1080p
Family.Guy.S19E02.1080p.HULU.WEB-DL.DDP5.1.H264.Eng.Hun-BNR
Family.Guy.S19E03.WEBRip.x264.Hun-BNR
Family.Guy.S19E02.720p.HULU.WEB-DL.DDP5.1.H264.Eng.Hun-BNR
Family.Guy.S19E20.1080p.WEB.H264-CAKES
Deluge-YaRSS2';
my $regex = qr/the.100.S01E\d{1,2}.*720p.*hun.eng.*sln|the.100.S\d{1,2}.*720p.*hun.eng.*sln/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}