$re = '/^[M]{12,15}/m';
$str = 'MMMMMMMMMMMMMM
M1234567890123
coucou MMMMMMMMMMMMM ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);