const regex = /^[0-9a-fA-F:]+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[0-9a-fA-F:]+$', 'gm')
const str = `123ABC:DEF456
0:1:2:3:4:5
12345
90210-1234`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}