$re = '/^
(?=[^J]*J)
(?=[^D]*D)
(?=[^B]*(?:B[^B]*){2})
[^A]*(?:A[^A]*){2}.*/mx';
$str = 'ABZBABJDCDAZ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);