#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^\\\\\w+)(\\{1}\w+)+(.+(?<!\\)$)"
Local $sString = "\\server\multiple\folders\example\path" & @CRLF & _
"\\server\\multiple\folders\example\path" & @CRLF & _
"\\server\multiple\\folders\example\path" & @CRLF & _
"\\server\multiple\folders\example\path\" & @CRLF & _
"\\server" & @CRLF & _
"\\\server\multiple" & @CRLF & _
"\\server\m" & @CRLF & _
"\\server\m\w\z"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")