#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:^####(.*)\R)?^(OVERVIEW|INTRODUCTION|DETAILS)\R(?s:(.*?))(?=^####|^(?:OVERVIEW|INTRODUCTION|DETAILS)$|\z)"
Local $sString = "<Irrelevant line>" & @CRLF & _
"..." & @CRLF & _
"<Irrelevant line>" & @CRLF & _
"####<section_title>" & @CRLF & _
"OVERVIEW" & @CRLF & _
"..." & @CRLF & _
"..." & @CRLF & _
"INTRODUCTION" & @CRLF & _
"..." & @CRLF & _
"..." & @CRLF & _
"DETAILS" & @CRLF & _
"..." & @CRLF & _
"..." & @CRLF & _
"####<section_title>" & @CRLF & _
"OVERVIEW" & @CRLF & _
"..." & @CRLF & _
"..." & @CRLF & _
"INTRODUCTION" & @CRLF & _
"..." & @CRLF & _
"..." & @CRLF & _
"DETAILS" & @CRLF & _
"..." & @CRLF & _
"..."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")