re = /\$\[\((.*)\)\]/
str = '$[(Something)] $[(something)]
$[(Something)]$[(something)]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end