$re = '/(0[1-9]|[12][0-9]|3[01]):(0[1-9]|1[012]):(\d{1,4})\s+(\d{1,2}):(\d{1,2})\s+-\s+(\w{2})/m';
$str = '21:10:1999 12:12 - ss
01:10:1999 12:12 - ss
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);