#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\[([^]]*)\](.*\n?(?!^\[))*"
Local $sString = "[My Custom Exe][2018-05-24 11:03:01] Starting Process" & @CRLF & _
"[My Custom Exe][2018-05-24 11:03:01] Getting config" & @CRLF & _
"[My Custom Exe][2018-05-24 11:03:02] Beginning operation" & @CRLF & _
"[My Custom Exe][2018-05-24 11:03:02] Could not complete this operation, invalid inputs" & @CRLF & _
"[My Custom Exe][2018-05-24 11:03:02] Available inputs are:" & @CRLF & _
"" & @CRLF & _
"- 1: Mode 1" & @CRLF & _
"- 2: Mode 2" & @CRLF & _
"- 3: Mode 3" & @CRLF & _
"- 4: Mode 4" & @CRLF & _
"- 5: Mode 5" & @CRLF & _
"" & @CRLF & _
"[My Custom Exe][2018-05-24 11:03:02] Exiting Program"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")