package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?i)^i`)
var str = `Itestcol
itestcol2
anyothericol`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}