#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:25[0-5]|2[0-4][0-9]|1[0-9][0-9]|[1-9]?[0-9])(?=(?:\.(?:(?:25[0-5]|2[0-4][0-9]|1[0-9][0-9]|[1-9]?[0-9])|\*)){3}$)(?:\.(?:25[0-5]|2[0-4][0-9]|1[0-9][0-9]|[1-9]?[0-9]))*(?:\.\*)*$"
Local $sString = "192.168.1.1" & @CRLF & _
"" & @CRLF & _
"192.168.1.*" & @CRLF & _
"" & @CRLF & _
"192.168.*.*" & @CRLF & _
"" & @CRLF & _
"192.*.*.*" & @CRLF & _
"" & @CRLF & _
"192.168.*.1" & @CRLF & _
"" & @CRLF & _
"192.*.1.1" & @CRLF & _
"" & @CRLF & _
"192.*.*.1" & @CRLF & _
"" & @CRLF & _
"*.168.1.1" & @CRLF & _
"" & @CRLF & _
"192.*" & @CRLF & _
"" & @CRLF & _
"001.1.1.1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")