import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)(?=(((\\()?(red|gold|silver|king)( pack)?(\\))?)|((70|83|84|100|120)(s|'s)?)))((((\\()?(red|gold|silver|king)( pack)?(\\))? )?((70|83|84|100|120)(s|'s)? )?)(\\bbox\\b))";
final String string = "Python does not support conditionals using lookaround, even though Python does support lookaround outside conditionals. Instead of a conditional like (?(?=regex)then|else), you can alternate two opposite lookarounds: (?=regex)then|(?!regex)else.\n\n"
+ "https://www.regular-expressions.info/lookaround.html\n"
+ "https://www.regular-expressions.info/conditional.html\n\n"
+ "LOOKAHEAD to see if EITHER pattern1 or pattern2 exists\n"
+ "pattern1 = ((\\()?(red|gold|silver|king)( pack)?(\\))?)\n"
+ "pattern2 = ((70|83|84|100|120)(s|'s)?)\n"
+ "IF one of the patterns exists in the string, THEN look for \n"
+ "pattern1 box\n"
+ "pattern2 box\n"
+ "pattern1 pattern2 box\n"
+ " \n"
+ "IS NOT cases - things that I do NOT want to match\n"
+ "box\n"
+ " box\n"
+ "Marlboro Box - this is a perfect example of a NOT case - I do NOT want to match this string\n"
+ "OR maybe I do ... ARGH - NO I do not want to match BOX!!\n"
+ "moving box - example that I NEVER want to match ... ARGHHH\n"
+ "junk 's matchbox car\n"
+ "matchboxracer\n"
+ "boxer - we NEVER think about the NOT cases ... lol mitch and I fought about this for years. recently he meantioned the NEED for NOT\n\n"
+ "IS cases - aka - things that I WANT TO MATCH\n\n"
+ "Marlboro 100's Box\n"
+ "Marlboro Gold Pack 100's Box\n"
+ "Marlboro Special Blend (Gold Pack) 100's Box\n"
+ "Marlboro Silver Pack Box\n"
+ "Marlboro Special Blend (Red Pack) 100s Box\n"
+ "Pall Mall RED 100 BOX\n"
+ "Marlboro Special Blend (Gold Pack) Box\n\n\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}