package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\[v=)`)
var str = `oo_ios [v=111]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}