import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ":(?!:|\\s)([^\\s|\\/]{1,}?)(?=:)";
final String string = ": :smile:http://baidu.com:9090 :smile1:表情:测试1 :smile: :tv_可爱: :smile: :::::smile:: :tv_doge: ::::tv_doge:: :::tv_doge: : :::: :tv_doge: :::tv_doge::smile:smile:";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}