import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^-?((?:(?:\\d{1,3})+)?(?:(?:([\\s,])?\\d{3}))?(?:(?:\\2\\d{3})+)?)([\\-.,]\\d{2})?(\\srub\\.?)?$";
final String string = "-1000000.00\n"
+ "1000000.00\n"
+ "1000000.00 rub.\n"
+ "-1000000-00\n"
+ "1000000-00\n"
+ "1000000-00 rub.\n"
+ "-1000000,00\n"
+ "1000000,00\n"
+ "1000000,00 rub.\n"
+ "-1 000 000,00\n"
+ "1 000 000,00\n"
+ "1 000 000,00 rub.\n"
+ "-1,000,000.00\n"
+ "1,000,000.00\n"
+ "1,000,000.00 rub.\n"
+ "-1000000\n"
+ "1000000\n"
+ "1000000 rub\n"
+ "2.00 rub\n"
+ "4555.15\n"
+ "1 000,000 000-00";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}