$re = '~\bAM19/0(?!803)[678]\d{2}\b~m';
$str = 'AM19/0601
AM19/0805
AM19/0803';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);