$re = '/^(\D+)(\d{4})(\d{4})/m';
$str = 'xxx_05102019023601017.csv';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);