package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)userSession\"\svalue=\"([^\"]+)`)
var str = `"userSession" value="text"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}