# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(<tr[^>]*>)(?:\s*<t[dh][^>]*>[^<]*</t[dh]>){4}"
test_str = ("<table >\n"
" <thead>\n"
" <tr>\n"
" <th></th>\n"
" <th>Купить до</th>\n"
" <th>Реестр</th>\n"
" <th>Дата выплаты</th>\n"
" <th>Период </th>\n"
" <th >Дивиденд</th>\n"
" <th >Доходность</th>\n"
" <th >Цена на закрытии</th>\n"
" </tr>\n"
" </thead>\n"
" <tbody>\n"
" <tr >\n"
" <td > </td>\n"
" <td >3 дек 2021</td>\n"
" <td >7 дек 2021</td>\n"
" <td >21 дек 2021</td>\n"
" <td >3КВ 2021</td>\n"
" <td >13,33 ₽</td>\n"
" <td >6,06%</td>\n"
" <td></td>\n"
" </tr>\n"
" <tr >\n"
" <td > </td>\n"
" <td >3 сен 2021</td>\n"
" <td >7 сен 2021</td>\n"
" <td >21 сен 2021</td>\n"
" <td >2КВ 2021</td>\n"
" <td >13,62 ₽</td>\n"
" <td >5,53%</td>\n"
" <td > 246,32 ₽ </td>\n"
" </tr>\n"
" <tr >\n"
" <td > </td>\n"
" <td >21 июн 2021</td>\n"
" <td >23 июн 2021</td>\n"
" <td >7 июл 2021</td>\n"
" <td >1КВ 2021</td>\n"
" <td >7,71 ₽</td>\n"
" <td >2,98%</td>\n"
" <td > 259,04 ₽ </td>\n"
" </tr>\n"
" <tr >\n"
" <td > </td>\n"
" <td >7 мая 2021</td>\n"
" <td >11 мая 2021</td>\n"
" <td >25 мая 2021</td>\n"
" <td >4КВ 2020</td>\n"
" <td >7,25 ₽</td>\n"
" <td >2,63%</td>\n"
" <td > 276,02 ₽ </td>\n"
" </tr>\n"
" <tr >\n"
" <td > </td>\n"
" <td >25 дек 2020</td>\n"
" <td >29 дек 2020</td>\n"
" <td >12 янв 2021</td>\n"
" <td >3КВ 2020</td>\n"
" <td >6,43 ₽</td>\n"
" <td >2,87%</td>\n"
" <td > 224,36 ₽ </td>\n"
" </tr>\n"
" <tr >\n"
" <td > </td>\n"
" <td >8 окт 2020</td>\n"
" <td >12 окт 2020</td>\n"
" <td >26 окт 2020</td>\n"
" <td >2КВ 2020</td>\n"
" <td >4,75 ₽</td>\n"
" <td >2,73%</td>\n"
" <td > 174,28 ₽ </td>\n"
" </tr>\n"
" <tr >\n"
" <td > </td>\n"
" <td >9 июл 2020</td>\n"
" <td >13 июл 2020</td>\n"
" <td >27 июл 2020</td>\n"
" <td >1КВ 2020</td>\n"
" <td >3,21 ₽</td>\n"
" <td >2,29%</td>\n"
" <td > 140,22 ₽ </td>\n"
" </tr>\n"
" <tr >\n"
" <td > </td>\n"
" <td >5 июн 2020</td>\n"
" <td >9 июн 2020</td>\n"
" <td >23 июн 2020</td>\n"
" <td >4КВ 2019</td>\n"
" <td >3,12 ₽</td>\n"
" <td >2,2%</td>\n"
" <td > 142 ₽ </td>\n"
" </tr>\n"
" <tr >\n"
" <td > </td>\n"
" <td >6 янв 2020</td>\n"
" <td >9 янв 2020</td>\n"
" <td >23 янв 2020</td>\n"
" <td >3КВ 2019</td>\n"
" <td >3,22 ₽</td>\n"
" <td >2,27%</td>\n"
" <td > 141,94 ₽ </td>\n"
" </tr>\n"
" <tr >\n"
" <td > </td>\n"
" <td >8 окт 2019</td>\n"
" <td >10 окт 2019</td>\n"
" <td >24 окт 2019</td>\n"
" <td >2КВ 2019</td>\n"
" <td >3,68 ₽</td>\n"
" <td >2,8%</td>\n"
" <td > 131,58 ₽ </td>\n"
" </tr>\n"
" <tr >\n"
" <td > </td>\n"
" <td >17 июн 2019</td>\n"
" <td >19 июн 2019</td>\n"
" <td >3 июл 2019</td>\n"
" <td >1КВ 2019</td>\n"
" <td >7,34 ₽</td>\n"
" <td >4,03%</td>\n"
" <td > 182 ₽ </td>\n"
" </tr>\n"
" <tr >\n"
" <td > </td>\n"
" <td >2 мая 2019</td>\n"
" <td >6 мая 2019</td>\n"
" <td >20 мая 2019</td>\n"
" <td >4КВ 2018</td>\n"
" <td >5,80 ₽</td>\n"
" <td >3,31%</td>\n"
" <td > 175,08 ₽ </td>\n"
" </tr>\n"
" <tr >\n"
" <td > </td>\n"
" <td >4 янв 2019</td>\n"
" <td >9 янв 2019</td>\n"
" <td >23 янв 2019</td>\n"
" <td >3КВ 2018</td>\n"
" <td >6,04 ₽</td>\n"
" <td >3,88%</td>\n"
" <td > 155,68 ₽ </td>\n"
" </tr>\n"
" <tr >\n"
" <td > </td>\n"
" <td >10 окт 2018</td>\n"
" <td >12 окт 2018</td>\n"
" <td >26 окт 2018</td>\n"
" <td >2КВ 2018</td>\n"
" <td >5,24 ₽</td>\n"
" <td >2,97%</td>\n"
" <td > 176,34 ₽ </td>\n"
" </tr>\n"
" <tr >\n"
" <td > </td>\n"
" <td >18 июн 2018</td>\n"
" <td >20 июн 2018</td>\n"
" <td >4 июл 2018</td>\n"
" <td >4КВ 2017</td>\n"
" <td >3,36 ₽</td>\n"
" <td >2,01%</td>\n"
" <td > 167,3 ₽ </td>\n"
" </tr>\n"
" <tr >\n"
" <td > </td>\n"
" <td >18 июн 2018</td>\n"
" <td >20 июн 2018</td>\n"
" <td >4 июл 2018</td>\n"
" <td >1КВ 2018</td>\n"
" <td >5,73 ₽</td>\n"
" <td >3,42%</td>\n"
" <td > 167,3 ₽ </td>\n"
" </tr>\n"
" <tr >\n"
" <td > </td>\n"
" <td >4 янв 2018</td>\n"
" <td >9 янв 2018</td>\n"
" <td >23 янв 2018</td>\n"
" <td >3КВ 2017</td>\n"
" <td >5,13 ₽</td>\n"
" <td >3,35%</td>\n"
" <td > 153 ₽ </td>\n"
" </tr>\n"
" <tr >\n"
" <td > </td>\n"
" <td >10 окт 2017</td>\n"
" <td >12 окт 2017</td>\n"
" <td >26 окт 2017</td>\n"
" <td >2КВ 2017</td>\n"
" <td >3,20 ₽</td>\n"
" <td >2,33%</td>\n"
" <td > 137,4 ₽ </td>\n"
" </tr>\n"
" <tr >\n"
" <td > </td>\n"
" <td >9 июн 2017</td>\n"
" <td >14 июн 2017</td>\n"
" <td >28 июн 2017</td>\n"
" <td >4КВ 2016</td>\n"
" <td >3,38 ₽</td>\n"
" <td >3,1%</td>\n"
" <td > 109,19 ₽ </td>\n"
" </tr>\n"
" <tr >\n"
" <td > </td>\n"
" <td >9 июн 2017</td>\n"
" <td >14 июн 2017</td>\n"
" <td >28 июн 2017</td>\n"
" <td >1КВ 2017</td>\n"
" <td >2,35 ₽</td>\n"
" <td >2,15%</td>\n"
" <td > 109,19 ₽ </td>\n"
" </tr>\n"
" <tr >\n"
" <td > </td>\n"
" <td >5 янв 2017</td>\n"
" <td >9 янв 2017</td>\n"
" <td >23 янв 2017</td>\n"
" <td >3КВ 2016</td>\n"
" <td >3,63 ₽</td>\n"
" <td >3,13%</td>\n"
" <td > 116 ₽ </td>\n"
" </tr>\n"
" <tr >\n"
" <td > </td>\n"
" <td >10 окт 2016</td>\n"
" <td >12 окт 2016</td>\n"
" <td >26 окт 2016</td>\n"
" <td >2КВ 2016</td>\n"
" <td >1,08 ₽</td>\n"
" <td >1,23%</td>\n"
" <td > 87,85 ₽ </td>\n"
" </tr>\n"
" <tr >\n"
" <td > </td>\n"
" <td >9 июн 2016</td>\n"
" <td >14 июн 2016</td>\n"
" <td >28 июн 2016</td>\n"
" <td >1КВ 2016</td>\n"
" <td >1,13 ₽</td>\n"
" <td >1,4%</td>\n"
" <td > 80,51 ₽ </td>\n"
" </tr>\n"
" <tr >\n"
" <td > </td>\n"
" <td >9 июн 2016</td>\n"
" <td >14 июн 2016</td>\n"
" <td >28 июн 2016</td>\n"
" <td >4КВ 2015</td>\n"
" <td >2,43 ₽</td>\n"
" <td >3,02%</td>\n"
" <td > 80,51 ₽ </td>\n"
" </tr>\n"
" <tr >\n"
" <td > </td>\n"
" <td >5 янв 2016</td>\n"
" <td >8 янв 2016</td>\n"
" <td >22 янв 2016</td>\n"
" <td >3КВ 2015</td>\n"
" <td >1,95 ₽</td>\n"
" <td >3,21%</td>\n"
" <td > 60,75 ₽ </td>\n"
" </tr>\n"
" <tr >\n"
" <td > </td>\n"
" <td >8 окт 2015</td>\n"
" <td >12 окт 2015</td>\n"
" <td >26 окт 2015</td>\n"
" <td >2КВ 2015</td>\n"
" <td >0,93 ₽</td>\n"
" <td >1,28%</td>\n"
" <td > 72,75 ₽ </td>\n"
" </tr>\n"
" <tr >\n"
" <td > </td>\n"
" <td >11 июн 2015</td>\n"
" <td >16 июн 2015</td>\n"
" <td >30 июн 2015</td>\n"
" <td >2П 2014</td>\n"
" <td >1,56 ₽</td>\n"
" <td >2,14%</td>\n"
" <td > 72,8 ₽ </td>\n"
" </tr>\n"
" <tr >\n"
" <td > </td>\n"
" <td >11 июн 2015</td>\n"
" <td >16 июн 2015</td>\n"
" <td >30 июн 2015</td>\n"
" <td >1КВ 2015</td>\n"
" <td >1,64 ₽</td>\n"
" <td >2,25%</td>\n"
" <td > 72,8 ₽ </td>\n"
" </tr>\n"
" <tr >\n"
" <td > </td>\n"
" <td >8 окт 2014</td>\n"
" <td >11 окт 2014</td>\n"
" <td >24 окт 2014</td>\n"
" <td >1П 2014</td>\n"
" <td >0,88 ₽</td>\n"
" <td >1,61%</td>\n"
" <td > 54,65 ₽ </td>\n"
" </tr>\n"
" <tr >\n"
" <td > </td>\n"
" <td >11 июн 2014</td>\n"
" <td >17 июн 2014</td>\n"
" <td >1 июл 2014</td>\n"
" <td >2013</td>\n"
" <td >0,67 ₽</td>\n"
" <td >1,39%</td>\n"
" <td > 48,33 ₽ </td>\n"
" </tr>\n"
" <tr >\n"
" <td > </td>\n"
" <td >24 апр 2013</td>\n"
" <td >24 апр 2013</td>\n"
" <td >8 мая 2013</td>\n"
" <td >2012</td>\n"
" <td >0,62 ₽</td>\n"
" <td >1,15%</td>\n"
" <td > 53,91 ₽ </td>\n"
" </tr>\n"
" <tr >\n"
" <td > </td>\n"
" <td >10 апр 2012</td>\n"
" <td >10 апр 2012</td>\n"
" <td >24 апр 2012</td>\n"
" <td >2П 2011</td>\n"
" <td >0,60 ₽</td>\n"
" <td >0,99%</td>\n"
" <td > 60,61 ₽ </td>\n"
" </tr>\n"
" <tr >\n"
" <td > </td>\n"
" <td >15 авг 2011</td>\n"
" <td >15 авг 2011</td>\n"
" <td >29 авг 2011</td>\n"
" <td >1П 2011</td>\n"
" <td >1,40 ₽</td>\n"
" <td >1,67%</td>\n"
" <td > 83,98 ₽ </td>\n"
" </tr>\n"
" <tr >\n"
" <td > </td>\n"
" <td >17 апр 2011</td>\n"
" <td >17 апр 2011</td>\n"
" <td >29 апр 2011</td>\n"
" <td >2П 2010</td>\n"
" <td >1,20 ₽</td>\n"
" <td >1,07%</td>\n"
" <td > 111,89 ₽ </td>\n"
" </tr>\n"
" <tr >\n"
" <td > </td>\n"
" <td >25 авг 2010</td>\n"
" <td >25 авг 2010</td>\n"
" <td >8 сен 2010</td>\n"
" <td >1П 2010</td>\n"
" <td >0,62 ₽</td>\n"
" <td >0,71%</td>\n"
" <td > 87,35 ₽ </td>\n"
" </tr>\n"
" <tr >\n"
" <td > </td>\n"
" <td >16 апр 2010</td>\n"
" <td >16 апр 2010</td>\n"
" <td >30 апр 2010</td>\n"
" <td >2009</td>\n"
" <td >0,22 ₽</td>\n"
" <td >0,2%</td>\n"
" <td > 110,79 ₽ </td>\n"
" </tr>\n"
" <tr >\n"
" <td > </td>\n"
" <td >1 авг 2008</td>\n"
" <td >1 авг 2008</td>\n"
" <td >15 авг 2008</td>\n"
" <td >1П 2008</td>\n"
" <td >2,00 ₽</td>\n"
" <td >1,91%</td>\n"
" <td > 104,53 ₽ </td>\n"
" </tr>\n"
" <tr >\n"
" <td > </td>\n"
" <td >18 апр 2008</td>\n"
" <td >18 апр 2008</td>\n"
" <td >2 мая 2008</td>\n"
" <td >2П 2007</td>\n"
" <td >1,5 ₽</td>\n"
" <td >1,32%</td>\n"
" <td > 114 ₽ </td>\n"
" </tr>\n"
" </tbody>\n"
"</table>")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.