using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=<a href=\"")(.*)(?=\.html\"">)";
string input = @"<div id=""breadcrumb-section"">
<ol id=""breadcrumbs"">
<li class=""first"">
<span>
<a href=""index.html"">Technologies</a>
</span>
</li>
<li>
<span>
<a href=""Some-Technologies-Documentation_218464400.html"">Some Technologies Documentation</a>
</span>
</li>
<li>
<span>
<a href=""Some-Other-Documentation_268370090.html"">Some Other Documentation</a>
</span>
</li>
<li>
<span>
<a href=""Another-Documentation_268370112.html"">Another Documentation</a>
</span>
</li>
</ol>
</div>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}