re = /(?:^|\W)(?:@)(\w(?:(?:\w|(?:\.(?!\.))){0,28}(?:\w))?)/m
str = '@outlook iam@outlook.com
@outlook.com @soand.so.and.so
but@not.com this.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end