package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m):\s*([a-z\s-]*?)\s*-*year`)
var str = `history: four year-old boy was really sad when he found
out the toy was broken`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}