import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^CTR.*";
final String string = "CTRasdkljfhalksjdfhalksjdfhalskjhf\n"
+ "2f3232rjfkalkj23f2a523gap289gaCTR\n"
+ "23rCTRCTRs;flkjs;ldfjkCTR\n"
+ "CTR23dfhalskjhf\n"
+ "CTRasdkljfhalksjd234251dfhalskjhf\n"
+ "CTRasdkljf3623462346jdfhalskjhf";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}