using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"2(\d{2})[\r\n](.{12})\s{2}(.{8})\s(.{8})[\r\n](.{31})[\r\n]\s*(\S*)\s*P#(.{12})[\r\n](.{31})[\r\n].*[\r\n]\s*(\S*)[\r\n]\s*(\S*)\s*(\S*).*[\r\n].*[\r\n]\s*(\S*)\s*(\S*).*[\r\n]\s*(\S*)\s*(\S*).*[\r\n]\s*(\S*)\s*(\S*).*[\r\n]\s*(\S*)\s*(\S*)\s*(\S*).*[\r\n]\s*(\S*).*[\r\n]\s*(.{12}).*[\r\n](.{19}).*[\r\n].*";
string input = @"201
541-303-1291 05/28/20 13:29:55
MUNSELL,MAJORIE
865 P#541-303-1291
W RIDGEWAY AVE
ESN=06204
HERMISTON OR
CLASS:RESD TEL=CHTR
LAT: LON:
METERS: PERCENT:
ELV SPD DIR
PSAP=HERM
HERMISTON PD
UMATILLA COUNTY FD1
UMATILLA COUNTY FD1 ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}