import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^\\+[0-9]{2}|^\\+[0-9]{2}\\(0\\)|^\\(\\+[0-9]{2}\\)\\(0\\)|^00[0-9]{2}|^0)([0-9]{9}$|[0-9\\-\\s]{10}$)";
final String string = "Starts with either: +31, +31(0), (+31)(0), 0031, 0 followed by 10 digits, '-' or space\n"
+ "First part: \n"
+ "+311234567890\n"
+ "+31(0)1234567890\n"
+ "(+31)(0)1234567890\n"
+ "00311234567890\n"
+ "01234567890\n\n"
+ "Second part:\n"
+ "0031123456789-\n"
+ "003112345 789-\n"
+ "0031-23456780-\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}