$re = '/^(?:0|\+27)?/m';
$str = '797734809
0797734809
27797734809
+27797734809';
$subst = "+27";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;